import re
regex = re.compile(r"rel=['\"](?:shortcut )?icon['\"] href=['\"]([^?'\"]+)[?'\"]")
test_str = ("<link rel=\"shortcut icon\" href=\"https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196\">\n"
"<link rel=\"icon\" href=\"https://www.ecotechie.io/wp-content/uploads/2019/05/cropped-EcoTechie-Logo-512x512-1-32x32.png\" sizes=\"32x32\" />\n"
"<link rel=\"icon\" href=\"//ssl.gstatic.com/pagespeed/insights/ui/logo/favicon_48.png\" sizes=\"48x48\">\n"
"<link rel='shortcut icon' href='https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196'>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")