re = /rel=['"](?:shortcut )?icon['"] href=['"]([^?'"]+)[?'"]/
str = '<link rel="shortcut icon" href="https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196">
<link rel="icon" href="https://www.ecotechie.io/wp-content/uploads/2019/05/cropped-EcoTechie-Logo-512x512-1-32x32.png" sizes="32x32" />
<link rel="icon" href="//ssl.gstatic.com/pagespeed/insights/ui/logo/favicon_48.png" sizes="48x48">
<link rel=\'shortcut icon\' href=\'https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196\'>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end