# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[\x20\t\r\n\f]+|((?:^|[^\\])(?:\\.)*)[\x20\t\r\n\f]+$//gm;t' <<< "
\\
\\\
\\\\
dfasdf
.some.thing#hi
#boob\\s
what\8
.blah
"