re = /^[\x20\t\r\n\f]+|((?:^|[^\\])(?:\\.)*)[\x20\t\r\n\f]+$/m
str = '
\\\\
\\\\\\
\\\\\\\\
dfasdf
.some.thing#hi
#boob\\\\s
what\\8
.blah
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result