package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\x20\t\r\n\f]+|((?:^|[^\\])(?:\\.)*)[\x20\t\r\n\f]+$`)
var str = `
\\
\\\
\\\\
dfasdf
.some.thing#hi
#boob\\s
what\8
.blah
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}