use strict;
my $str = '
\\\\
\\\\\\
\\\\\\\\
dfasdf
.some.thing#hi
#boob\\\\s
what\\8
.blah
';
my $regex = qr/^[\x20\t\r\n\f]+|((?:^|[^\\])(?:\\.)*)[\x20\t\r\n\f]+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";