#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[\x20\t\r\n\f]+|((?:^|[^\\])(?:\\.)*)[\x20\t\r\n\f]+$"
Local $sString = " " & @CRLF & _
"\\" & @CRLF & _
"" & @CRLF & _
"\\\" & @CRLF & _
"" & @CRLF & _
"\\\\" & @CRLF & _
"" & @CRLF & _
"dfasdf" & @CRLF & _
"" & @CRLF & _
".some.thing#hi" & @CRLF & _
"#boob\\s" & @CRLF & _
"" & @CRLF & _
"what\8" & @CRLF & _
"" & @CRLF & _
".blah" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)