#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)B\d{3}"
Local $sString = "Brought my Sony A5000 for my trip" & @CRLF & _
"the Airbus A220v300's bathroom has a window" & @CRLF & _
"My favorite jet is the B737-900ER flew it like x 239" & @CRLF & _
"all stan the queen B747, 120% the B333st" & @CRLF & _
"I like the chonky A380" & @CRLF & _
"but I love the A350"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")