use strict;
my $str = 'Brought my Sony A5000 for my trip
the Airbus A220v300\'s bathroom has a window
My favorite jet is the B737-900ER flew it like x 239
all stan the queen B747, 120% the B333st
I like the chonky A380
but I love the A350';
my $regex = qr/B\d{3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}