$re = '/B\d{3}/m';
$str = 'Brought my Sony A5000 for my trip
the Airbus A220v300\'s bathroom has a window
My favorite jet is the B737-900ER flew it like x 239
all stan the queen B747, 120% the B333st
I like the chonky A380
but I love the A350';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);