import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "B\\d{3}";
final String string = "Brought my Sony A5000 for my trip\n"
+ "the Airbus A220v300's bathroom has a window\n"
+ "My favorite jet is the B737-900ER flew it like x 239\n"
+ "all stan the queen B747, 120% the B333st\n"
+ "I like the chonky A380\n"
+ "but I love the A350";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}