import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<date>(?:\\d+)\\/\\d+\\/\\d+)\\s+(?<time>(?:\\d+:){2}\\d+)\\s+(?<proc>\\w+)\\s(?<log_level>\\w+)\\s(?<message>.*?(?:ID: (?<ID>\\d+).*)?)$";
final String string = "10/22/2021 8:56:35 test Warning ID: 111 OD: 00:00:01 blah blah blah blah\n"
+ "10/22/2021 8:56:35 test Warning OD: 00:00:01 blah blah blah blah";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}