import re
regex = re.compile(r"^(?<date>(?:\d+)\/\d+\/\d+)\s+(?<time>(?:\d+:){2}\d+)\s+(?<proc>\w+)\s(?<log_level>\w+)\s(?<message>.*?(?:ID: (?<ID>\d+).*)?)$", flags=re.MULTILINE)
test_str = ("10/22/2021 8:56:35 test Warning ID: 111 OD: 00:00:01 blah blah blah blah\n"
"10/22/2021 8:56:35 test Warning OD: 00:00:01 blah blah blah blah")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")