$re = '/^(?<date>(?:\d+)\/\d+\/\d+)\s+(?<time>(?:\d+:){2}\d+)\s+(?<proc>\w+)\s(?<log_level>\w+)\s(?<message>.*?(?:ID: (?<ID>\d+).*)?)$/m';
$str = '10/22/2021 8:56:35 test Warning ID: 111 OD: 00:00:01 blah blah blah blah
10/22/2021 8:56:35 test Warning OD: 00:00:01 blah blah blah blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);