const regex = /^(?<date>(?:\d+)\/\d+\/\d+)\s+(?<time>(?:\d+:){2}\d+)\s+(?<proc>\w+)\s(?<log_level>\w+)\s(?<message>.*?(?:ID: (?<ID>\d+).*)?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<date>(?:\\d+)\\\/\\d+\\\/\\d+)\\s+(?<time>(?:\\d+:){2}\\d+)\\s+(?<proc>\\w+)\\s(?<log_level>\\w+)\\s(?<message>.*?(?:ID: (?<ID>\\d+).*)?)$', 'gm')
const str = `10/22/2021 8:56:35 test Warning ID: 111 OD: 00:00:01 blah blah blah blah
10/22/2021 8:56:35 test Warning OD: 00:00:01 blah blah blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}