// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<date>(?:\d+)\/\d+\/\d+)\s+(?<time>(?:\d+:){2}\d+)\s+(?<proc>\w+)\s(?<log_level>\w+)\s(?<message>.*?(?:ID: (?<ID>\d+).*)?)$").unwrap();
let string = "10/22/2021 8:56:35 test Warning ID: 111 OD: 00:00:01 blah blah blah blah
10/22/2021 8:56:35 test Warning OD: 00:00:01 blah blah blah blah";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}