using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.\s+(Nature and purpose of financial analysis|Users and decision making)\s+(?:An|We)";
string substitution = @"\n";
string input = @"""As discussed in chapter 1, the users of financial statements can be categorised as resource provider. Users and decision making An example for this. Nature and purpose of financial analysis We have identi fied that financial analysis mvolves expressing reported numbers in financial statements in relative terms. """;
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}