import Foundation
let pattern = #"\.\s+(Nature and purpose of financial analysis|Users and decision making)\s+(?:An|We)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""As discussed in chapter 1, the users of financial statements can be categorised as resource provider. Users and decision making An example for this. Nature and purpose of financial analysis We have identi fied that financial analysis mvolves expressing reported numbers in financial statements in relative terms. ""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)