re = /\.\s+(Nature and purpose of financial analysis|Users and decision making)\s+(?:An|We)/
str = '"As discussed in chapter 1, the users of financial statements can be categorised as resource provider. Users and decision making An example for this. Nature and purpose of financial analysis We have identi fied that financial analysis mvolves expressing reported numbers in financial statements in relative terms. "'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result