use strict;
my $str = '"As discussed in chapter 1, the users of financial statements can be categorised as resource provider. Users and decision making An example for this. Nature and purpose of financial analysis We have identi fied that financial analysis mvolves expressing reported numbers in financial statements in relative terms. "';
my $regex = qr/\.\s+(Nature and purpose of financial analysis|Users and decision making)\s+(?:An|We)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";