using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?=\w{2,3}\b)(?:\d+[a-zA-Z]*|[a-zA-Z]+\d*)-){2,}(?:\d+[a-zA-Z]*|[a-zA-Z]+\d*)\b(?!-)";
string input = @"54-PT-001
54-PT-001A
JKS-54-002AB
KS-54-002B
JKS-64-002A
JKS-64-002B
AAA-54-002A
AAA-54-002
JKS-54-PT-002B
JKS-54-PT-002A
ABC-123-DEF-456-GHI-789
Shoudln't match:
only two segments:
JKS-54
mix of letter-number-letter
A1C-PT-0000
mix of number-letter-number
1A2-PT-0000
Non-final element is longer than 3 chars:
FOUR-PT-0000
XXX-FOUR-0000
Trailing dash
ABC-123-GHIJ-
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}