const regex = /\b(?:(?=\w{2,3}\b)(?:\d+[a-zA-Z]*|[a-zA-Z]+\d*)-){2,}(?:\d+[a-zA-Z]*|[a-zA-Z]+\d*)\b(?!-)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?=\\w{2,3}\\b)(?:\\d+[a-zA-Z]*|[a-zA-Z]+\\d*)-){2,}(?:\\d+[a-zA-Z]*|[a-zA-Z]+\\d*)\\b(?!-)', 'gm')
const str = `54-PT-001
54-PT-001A
JKS-54-002AB
KS-54-002B
JKS-64-002A
JKS-64-002B
AAA-54-002A
AAA-54-002
JKS-54-PT-002B
JKS-54-PT-002A
ABC-123-DEF-456-GHI-789
Shoudln't match:
only two segments:
JKS-54
mix of letter-number-letter
A1C-PT-0000
mix of number-letter-number
1A2-PT-0000
Non-final element is longer than 3 chars:
FOUR-PT-0000
XXX-FOUR-0000
Trailing dash
ABC-123-GHIJ-
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}