# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:(?=\w{2,3}\b)(?:\d+[a-zA-Z]*|[a-zA-Z]+\d*)-){2,}(?:\d+[a-zA-Z]*|[a-zA-Z]+\d*)\b(?!-)"
test_str = ("54-PT-001\n"
"54-PT-001A\n"
"JKS-54-002AB\n"
"KS-54-002B\n"
"JKS-64-002A\n"
"JKS-64-002B\n"
"AAA-54-002A\n"
"AAA-54-002\n"
"JKS-54-PT-002B\n"
"JKS-54-PT-002A\n"
"ABC-123-DEF-456-GHI-789\n\n"
"Shoudln't match:\n\n"
"only two segments:\n"
"JKS-54\n\n"
"mix of letter-number-letter\n"
"A1C-PT-0000\n\n"
"mix of number-letter-number\n"
"1A2-PT-0000\n\n"
"Non-final element is longer than 3 chars:\n"
"FOUR-PT-0000\n"
"XXX-FOUR-0000\n\n"
"Trailing dash\n"
"ABC-123-GHIJ-\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.