use strict;
my $str = '54-PT-001
54-PT-001A
JKS-54-002AB
KS-54-002B
JKS-64-002A
JKS-64-002B
AAA-54-002A
AAA-54-002
JKS-54-PT-002B
JKS-54-PT-002A
ABC-123-DEF-456-GHI-789
Shoudln\'t match:
only two segments:
JKS-54
mix of letter-number-letter
A1C-PT-0000
mix of number-letter-number
1A2-PT-0000
Non-final element is longer than 3 chars:
FOUR-PT-0000
XXX-FOUR-0000
Trailing dash
ABC-123-GHIJ-
';
my $regex = qr/\b(?:(?=\w{2,3}\b)(?:\d+[a-zA-Z]*|[a-zA-Z]+\d*)-){2,}(?:\d+[a-zA-Z]*|[a-zA-Z]+\d*)\b(?!-)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}