import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?=\\w{2,3}\\b)(?:\\d+[a-zA-Z]*|[a-zA-Z]+\\d*)-){2,}(?:\\d+[a-zA-Z]*|[a-zA-Z]+\\d*)\\b(?!-)";
final String string = "54-PT-001\n"
+ "54-PT-001A\n"
+ "JKS-54-002AB\n"
+ "KS-54-002B\n"
+ "JKS-64-002A\n"
+ "JKS-64-002B\n"
+ "AAA-54-002A\n"
+ "AAA-54-002\n"
+ "JKS-54-PT-002B\n"
+ "JKS-54-PT-002A\n"
+ "ABC-123-DEF-456-GHI-789\n\n"
+ "Shoudln't match:\n\n"
+ "only two segments:\n"
+ "JKS-54\n\n"
+ "mix of letter-number-letter\n"
+ "A1C-PT-0000\n\n"
+ "mix of number-letter-number\n"
+ "1A2-PT-0000\n\n"
+ "Non-final element is longer than 3 chars:\n"
+ "FOUR-PT-0000\n"
+ "XXX-FOUR-0000\n\n"
+ "Trailing dash\n"
+ "ABC-123-GHIJ-\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}