package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([A-Za-z0-9]+\w*[\.\-]?){1,}+\w*@([A-Za-z0-9]+\.){1,2}[A-z]{2,3})`)
var str = `this.is.a.test@foo.bar.com
pie@fizzbuzz.be
_pie_underscore-hyphen-@lamepun.us
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}