import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([A-Za-z0-9]+\\w*[\\.\\-]?){1,}+\\w*@([A-Za-z0-9]+\\.){1,2}[A-z]{2,3})";
final String string = "this.is.a.test@foo.bar.com\n"
+ "pie@fizzbuzz.be\n"
+ "_pie_underscore-hyphen-@lamepun.us\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}