import re
regex = re.compile(r"(([A-Za-z0-9]+\w*[\.\-]?){1,}+\w*@([A-Za-z0-9]+\.){1,2}[A-z]{2,3})")
test_str = ("this.is.a.test@foo.bar.com\n"
"pie@fizzbuzz.be\n"
"_pie_underscore-hyphen-@lamepun.us\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")