#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*-+ Page \d+-+\n"
Local $sString = "----------------------- Page 1-----------------------" & @CRLF & _
"text of page 1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"----------------------- Page 2-----------------------" & @CRLF & _
"text of page 2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"----------------------- Page 3-----------------------" & @CRLF & _
" text of page 3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")