const regex = new RegExp('\\s*-+ Page \\d+-+\\n', 'gm')
const str = `----------------------- Page 1-----------------------
text of page 1
----------------------- Page 2-----------------------
text of page 2
----------------------- Page 3-----------------------
text of page 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}