using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*-+ Page \d+-+\n";
string input = @"----------------------- Page 1-----------------------
text of page 1
----------------------- Page 2-----------------------
text of page 2
----------------------- Page 3-----------------------
text of page 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}