package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*-+ Page \d+-+\n`)
var str = `----------------------- Page 1-----------------------
text of page 1
----------------------- Page 2-----------------------
text of page 2
----------------------- Page 3-----------------------
text of page 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}