import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*-+ Page \\d+-+\\n";
final String string = "----------------------- Page 1-----------------------\n"
+ "text of page 1\n\n\n"
+ "----------------------- Page 2-----------------------\n"
+ "text of page 2\n\n\n"
+ "----------------------- Page 3-----------------------\n"
+ " text of page 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}