import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}-\\d{2}-\\d{2})(.*?)(?=\\d{4}-\\d{2}-\\d{2}|$)";
final String string = "2018-01-01\n\n"
+ "Stuff.\n\n"
+ "More Stuff.\n\n"
+ "2018-01-02\n\n"
+ "Different stuff.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}