$re = '/(\d{4}-\d{2}-\d{2})(.*?)(?=\d{4}-\d{2}-\d{2}|$)/s';
$str = '2018-01-01
Stuff.
More Stuff.
2018-01-02
Different stuff.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);