import re
regex = re.compile(r"(\d{4}-\d{2}-\d{2})(.*?)(?=\d{4}-\d{2}-\d{2}|$)", flags=re.DOTALL)
test_str = ("2018-01-01\n\n"
"Stuff.\n\n"
"More Stuff.\n\n"
"2018-01-02\n\n"
"Different stuff.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")