re = /(\d{4}-\d{2}-\d{2})(.*?)(?=\d{4}-\d{2}-\d{2}|$)/
str = '2018-01-01
Stuff.
More Stuff.
2018-01-02
Different stuff.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end