const regex = new RegExp('(\\d{4}-\\d{2}-\\d{2})(.*?)(?=\\d{4}-\\d{2}-\\d{2}|$)', 'gs')
const str = `2018-01-01
Stuff.
More Stuff.
2018-01-02
Different stuff.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}