using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\""|\')global_ok(\""|\')";
string input = @"var global_ok = LanguageManager.Instance.GetTextValue(""global_ok"");";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}