// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(\"|\')global_ok(\"|\')"#).unwrap();
let string = "var global_ok = LanguageManager.Instance.GetTextValue(\"global_ok\");";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}