#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{2})(\d{2})(?P<MM>\d{2})(?P<DD>\d{2})(?P<HH>\d{2})(?P<mm>\d{2})(?P<ss>\d{2})\.(?P<SSSSSS>\d{6})(?P<ZZ>[-+]\d{3,4})$"
Local $sString = "20201222152131.000000+120" & @CRLF & _
"" & @CRLF & _
"to" & @CRLF & _
"" & @CRLF & _
"12/22/20 15:21:31"
Local $sSubst = "$1/$2/$3 $4:$5:$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)