import re
regex = re.compile(r"^(\d{2})(\d{2})(?P<MM>\d{2})(?P<DD>\d{2})(?P<HH>\d{2})(?P<mm>\d{2})(?P<ss>\d{2})\.(?P<SSSSSS>\d{6})(?P<ZZ>[-+]\d{3,4})$", flags=re.MULTILINE)
test_str = ("20201222152131.000000+120\n\n"
"to\n\n"
"12/22/20 15:21:31")
subst = "$1/$2/$3 $4:$5:$6"
result = regex.sub(subst, test_str)
if result:
print(result)