use strict;
my $str = '20201222152131.000000+120
to
12/22/20 15:21:31';
my $regex = qr/^(\d{2})(\d{2})(?P<MM>\d{2})(?P<DD>\d{2})(?P<HH>\d{2})(?P<mm>\d{2})(?P<ss>\d{2})\.(?P<SSSSSS>\d{6})(?P<ZZ>[-+]\d{3,4})$/mp;
my $subst = '$1/$2/$3 $4:$5:$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";