package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^20([0-2][0-9])(\.(0[1-9]|1[012])(\.(0[1-9]|1[0-9]|2[0-9]|3[01]))?)?_([a-z]{1,24}((\-)?[a-z]{1,16})?)((\.[a-z]{1})|(\.[a-z]{1,16}\.[a-z]{1}))?_(([a-z]{1,24}((\-)?[a-z]{1,16})?)(\.[a-z]{1,16}(\.[a-z]{1,16}(\.[a-z]{1,16})?)?)?)?_(m|w)$`)
var str = `2012.11.09_mary.a_san.luis.obispo_w
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}