const regex = /^20([0-2][0-9])(\.(0[1-9]|1[012])(\.(0[1-9]|1[0-9]|2[0-9]|3[01]))?)?_([a-z]{1,24}((\-)?[a-z]{1,16})?)((\.[a-z]{1})|(\.[a-z]{1,16}\.[a-z]{1}))?_(([a-z]{1,24}((\-)?[a-z]{1,16})?)(\.[a-z]{1,16}(\.[a-z]{1,16}(\.[a-z]{1,16})?)?)?)?_(m|w)$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^20([0-2][0-9])(\\.(0[1-9]|1[012])(\\.(0[1-9]|1[0-9]|2[0-9]|3[01]))?)?_([a-z]{1,24}((\\-)?[a-z]{1,16})?)((\\.[a-z]{1})|(\\.[a-z]{1,16}\\.[a-z]{1}))?_(([a-z]{1,24}((\\-)?[a-z]{1,16})?)(\\.[a-z]{1,16}(\\.[a-z]{1,16}(\\.[a-z]{1,16})?)?)?)?_(m|w)$', 'm')
const str = `2012.11.09_mary.a_san.luis.obispo_w
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}