$re = '/^20([0-2][0-9])(\.(0[1-9]|1[012])(\.(0[1-9]|1[0-9]|2[0-9]|3[01]))?)?_([a-z]{1,24}((\-)?[a-z]{1,16})?)((\.[a-z]{1})|(\.[a-z]{1,16}\.[a-z]{1}))?_(([a-z]{1,24}((\-)?[a-z]{1,16})?)(\.[a-z]{1,16}(\.[a-z]{1,16}(\.[a-z]{1,16})?)?)?)?_(m|w)$/m';
$str = '2012.11.09_mary.a_san.luis.obispo_w
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);