using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^)(?=(\d{3})+(?=\.|$))";
string substitution = @" ";
string input = @"999999999
33333.25
222.32
4444";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}