using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(quote)=[^]]+\](?>(?R)|.)*?\[\/quote]";
string input = @"one,two,3,(4,five),six,(seven),,(8,9,ten),eleven,(twelve,13,14,fifteen)
[quote=test][quote=test]for sure[/quote]
Test
[/quote]
[this should not be removed]
Dont remove me
[quote=test]
s
[quote=test]for s
[quote=test]for sure[/quote]
sure[/quote]
Test2
[/quote]
x
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}