import Foundation
let pattern = #"\[(quote)=[^]]+\](?>(?R)|.)*?\[\/quote]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
one,two,3,(4,five),six,(seven),,(8,9,ten),eleven,(twelve,13,14,fifteen)
[quote=test][quote=test]for sure[/quote]
Test
[/quote]
[this should not be removed]
Dont remove me
[quote=test]
s
[quote=test]for s
[quote=test]for sure[/quote]
sure[/quote]
Test2
[/quote]
x
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)