# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(quote)=[^]]+\](?>(?R)|.)*?\[\/quote]"
test_str = ("one,two,3,(4,five),six,(seven),,(8,9,ten),eleven,(twelve,13,14,fifteen)\n\n"
"[quote=test][quote=test]for sure[/quote]\n"
"Test\n"
"[/quote]\n\n"
"[this should not be removed]\n"
"Dont remove me\n\n\n"
"[quote=test]\n"
"s\n"
"[quote=test]for s\n\n"
"[quote=test]for sure[/quote]\n\n"
"sure[/quote]\n\n"
"Test2\n"
"[/quote]\n\n"
"x\n\n")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.